Not resolved
1.6
Details
Diversity of Products or Services
Ease of Use
Exchange, Refund and Cancellation Policy
Price Affordability
Product or Service Quality
Staff
Style and Design
Value for money
Warranty
Website
5 comments

This is the second pair of the same type that just quit working. Worked fine for a week then just quit.

No response trying to pair them with devices and cannot turn the unit off by pressing the on off button. The blue Led light just keeps slowly blinking. Tryed charging but still got the same result. Isn't there any way to reset this unit.

Absolutely no help from your technical support, they were confused as I am. What do you suggest?

What kind of company are you to sell such a defective product . I am very upset because I can't find help anywhere at all.

Review about: Altec Lansing Evolution 2 Mzx667 Over-ear Headphones.

Reason of review: Damaged or defective.

Monetary Loss: $40.

Preferred solution: Let the company propose a solution.

I liked: Price.

I didn't like: Tech support, Product unreliable.

Do You Have Something To Say ?

Write a review

Comments

Terms of Service
Post Comment
Cancel
Anonymous
#1490588

Same thing happened to me. What I did was connect the aux cable to have a wired setup.

Listened to some music on my phone for 5mins. Took it out.

Tried bluetooth mode. Fixed!

Anonymous
#1485533

Same problem.

Anonymous
#1467894

Yup same problem, crap

Anonymous
#1419477

Same here. I am assuming still no solution?

spinsupreme
#1375240

I'm having the same issue. was working fine then ...

nothing. I can't turn them off as none of the buttons are working.

You May Also Like